From b8678b1f6c771d04da00aeb2f4f240ef0c2ba240 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Maximilian=20Ke=C3=9Fler?= <git@maximilian-kessler.de>
Date: Sun, 24 Oct 2021 00:44:49 +0200
Subject: [PATCH] set up gitlab ci. first try

---
 .travis/travis_build.sh => .ci/ci_build.sh    |  4 +-
 {.travis => .ci}/deploy/__init__.py           |  0
 {.travis => .ci}/deploy/deploy_message.py     |  0
 .../get_build_repo_from_origin.sh             |  7 +-
 {.travis => .ci}/print_deploy_message.py      |  0
 .gitlab-ci.yml                                | 82 +++++++++++++++++++
 Makefile                                      |  2 +-
 7 files changed, 89 insertions(+), 6 deletions(-)
 rename .travis/travis_build.sh => .ci/ci_build.sh (89%)
 rename {.travis => .ci}/deploy/__init__.py (100%)
 rename {.travis => .ci}/deploy/deploy_message.py (100%)
 rename {.travis => .ci}/get_build_repo_from_origin.sh (74%)
 rename {.travis => .ci}/print_deploy_message.py (100%)
 create mode 100644 .gitlab-ci.yml

diff --git a/.travis/travis_build.sh b/.ci/ci_build.sh
similarity index 89%
rename from .travis/travis_build.sh
rename to .ci/ci_build.sh
index 800aab1..77f3c60 100755
--- a/.travis/travis_build.sh
+++ b/.ci/ci_build.sh
@@ -1,7 +1,7 @@
-cd .travis
+cd .ci
 export COMMIT_MSG=$(python3 print_deploy_message.py)
 cd ..
-make travis
+make ci-build
 cd build
 zip -r LatexPackages.zip LatexPackagesBuild
 tree -H '.' -I "index.html" -D --charset utf-8 -T "LatexPackages" > index.html
diff --git a/.travis/deploy/__init__.py b/.ci/deploy/__init__.py
similarity index 100%
rename from .travis/deploy/__init__.py
rename to .ci/deploy/__init__.py
diff --git a/.travis/deploy/deploy_message.py b/.ci/deploy/deploy_message.py
similarity index 100%
rename from .travis/deploy/deploy_message.py
rename to .ci/deploy/deploy_message.py
diff --git a/.travis/get_build_repo_from_origin.sh b/.ci/get_build_repo_from_origin.sh
similarity index 74%
rename from .travis/get_build_repo_from_origin.sh
rename to .ci/get_build_repo_from_origin.sh
index 1ab021e..2fe26aa 100755
--- a/.travis/get_build_repo_from_origin.sh
+++ b/.ci/get_build_repo_from_origin.sh
@@ -1,13 +1,14 @@
 # ! /bin/sh
-git clone https://github.com/kesslermaximilian/LatexPackagesBuild.git build/LatexPackagesBuild
+ssh git@gitlab.com
+git clone git@gitlab.com:latexci/packages/LatexPackagesBuild.git build/LatexPackagesBuild
 cd build/LatexPackagesBuild
-REMOTE_BRANCH=$(git branch -a | sed -n '/remotes\/origin\/.*-build/p' | sed 's/remotes\/origin\///g' | sed 's/-build//g' | sed 's/[[:space:]]//g' | sed -n "/^${TRAVIS_BRANCH}$/p")
+REMOTE_BRANCH=$(git branch -a | sed -n '/remotes\/origin\/.*-build/p' | sed 's/remotes\/origin\///g' | sed 's/-build//g' | sed 's/[[:space:]]//g' | sed -n "/^${CI_COMMIT_REF_NAME}$/p")
 
 echo ${REMOTE_BRANCH}
 
 if [ "$REMOTE_BRANCH" = "" ];then
     echo "This is the first build on this branch, creating new branch in build repository to push to"
-    git checkout --orphan ${TRAVIS_BRANCH}-build
+    git checkout --orphan ${CI_COMMIT_REF_NAME}-build
     ls -ra | sed '/^\.git$/d' | sed '/^\.\.$/d' | sed '/^\.$/d' |  xargs -r git rm --cached
     ls -ra | sed '/^\.git$/d' | sed '/^\.\.$/d' | sed '/^\.$/d' |  xargs -r rm -rf
 else
diff --git a/.travis/print_deploy_message.py b/.ci/print_deploy_message.py
similarity index 100%
rename from .travis/print_deploy_message.py
rename to .ci/print_deploy_message.py
diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
new file mode 100644
index 0000000..0976970
--- /dev/null
+++ b/.gitlab-ci.yml
@@ -0,0 +1,82 @@
+stages:          # List of stages for jobs, and their order of execution
+  - get
+  - build
+  - deploy
+
+get-build-repo:       # This job runs in the build stage, which runs first.
+  stage: get
+  before_script:
+    - apt-get update -y && apt-get install -yqqf openssh-client git unzip sshpass rsync --fix-missing
+    - 'which ssh-agent || ( apt-get update -y && apt-get install openssh-client git -y )'
+    - eval $(ssh-agent -s)
+    - echo "$GITLAB_DEPLOY_KEY" | base64 -d | tr -d '\r' | ssh-add - > /dev/null
+
+    - mkdir -p ~/.ssh
+    - chmod 700 ~/.ssh
+
+    - ssh-keyscan gitlab.com >> ~/.ssh/known_hosts
+    - chmod 644 ~/.ssh/known_hosts
+
+    - git config --global user.email "git@maximilian-kessler.de"
+    - git config --global user.name "Maximilian Keßler (via gitlab runner)"
+  script:
+      - "Getting old Build repo..."
+      - .ci/get_build_repo_from_origin.sh
+  tags:
+    - latex
+  artifacts:
+    paths:
+      - build/
+
+build-packages:      # This job runs in the deploy stage.
+  stage: build  # It only runs when *both* jobs in the test stage complete successfully.
+  before_script:
+    - apt-get update -y && apt-get install -yqqf openssh-client git unzip sshpass rsync --fix-missing
+    - 'which ssh-agent || ( apt-get update -y && apt-get install openssh-client git -y )'
+    - eval $(ssh-agent -s)
+    - echo "$GITLAB_DEPLOY_KEY" | base64 -d | tr -d '\r' | ssh-add - > /dev/null
+
+    - mkdir -p ~/.ssh
+    - chmod 700 ~/.ssh
+
+    - ssh-keyscan gitlab.com >> ~/.ssh/known_hosts
+    - chmod 644 ~/.ssh/known_hosts
+
+    - git config --global user.email "git@maximilian-kessler.de"
+    - git config --global user.name "Maximilian Keßler (via gitlab runner)"
+  script:
+    - echo "Building packages incrementally..."
+    - .ci/ci_build.sh
+    - cd build/LatexPackagesBuild
+    - git add .
+    - git commit -m "${COMMIT_MESSAGE}"
+  artifacts:
+    paths:
+        - build/
+  tags:
+    - latex
+
+pages:
+  stage: deploy
+  artifacts:
+    paths:
+      - public
+  before_script:
+    - apt-get update -y && apt-get install -yqqf openssh-client git unzip sshpass rsync --fix-missing
+    - 'which ssh-agent || ( apt-get update -y && apt-get install openssh-client git -y )'
+    - eval $(ssh-agent -s)
+    - echo "$GITLAB_DEPLOY_KEY" | base64 -d | tr -d '\r' | ssh-add - > /dev/null
+
+    - mkdir -p ~/.ssh
+    - chmod 700 ~/.ssh
+
+    - ssh-keyscan gitlab.com >> ~/.ssh/known_hosts
+    - chmod 644 ~/.ssh/known_hosts
+
+    - git config --global user.email "git@maximilian-kessler.de"
+    - git config --global user.name "Maximilian Keßler (via gitlab runner)"
+  script:
+      - cd build/LatexPackagesBuild
+      - git push origin
+  tags:
+    - latex
diff --git a/Makefile b/Makefile
index 9e8113d..e98e350 100644
--- a/Makefile
+++ b/Makefile
@@ -28,5 +28,5 @@ config: .gitconfiglock
 clean:
 	@-rm -r build/
 
-travis:
+ci-build:
 	@python3 build.py --source-dir src --build-dir build/LatexPackagesBuild ${BUILD_FLAGS}