university-setup-git/PKGBUILD

31 lines
805 B
Bash

# Maintainer: Maximilian Keßler <git@maximilian-kessler.de>
#
pkgname=university-setup-git
pkgver=r118.2ebd7f4
pkgrel=1
pkgdesc="University setup scripts"
arch=(any)
url="https://git.abstractnonsen.se/max/university-setup"
license=("MIT")
depends=("python" "python-dateutil" "python-pytz" "python-yaml")
optdepends=("python-google-api-python-client: for google calendar integration"
"python-google-auth-oauthlib: for google calendar integration")
makedepends=("git")
provides=(university-setup)
conflicts=(university-setup)
source=("$pkgname::git+https://git.abstractnonsen.se/max/university-setup.git")
sha512sums=("SKIP")
pkgver() {
cd "$pkgname"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
cd "$pkgname"
DESTDIR="$pkgdir" make install
}